F_JustWei's Studio.

L2-021 点赞狂魔

字数统计: 726阅读时长: 3 min
2021/04/21 Share

L2-021 点赞狂魔 (25 分)

微博上有个“点赞”功能,你可以为你喜欢的博文点个赞表示支持。每篇博文都有一些刻画其特性的标签,而你点赞的博文的类型,也间接刻画了你的特性。然而有这么一种人,他们会通过给自己看到的一切内容点赞来狂刷存在感,这种人就被称为“点赞狂魔”。他们点赞的标签非常分散,无法体现出明显的特性。本题就要求你写个程序,通过统计每个人点赞的不同标签的数量,找出前3名点赞狂魔。

输入格式:

输入在第一行给出一个正整数N(≤100),是待统计的用户数。随后N行,每行列出一位用户的点赞标签。格式为“Name K F1⋯F**K”,其中Name是不超过8个英文小写字母的非空用户名,1≤K≤1000,F**ii=1,⋯,K)是特性标签的编号,我们将所有特性标签从 1 到 107 编号。数字间以空格分隔。

输出格式:

统计每个人点赞的不同标签的数量,找出数量最大的前3名,在一行中顺序输出他们的用户名,其间以1个空格分隔,且行末不得有多余空格。如果有并列,则输出标签出现次数平均值最小的那个,题目保证这样的用户没有并列。若不足3人,则用-补齐缺失,例如mike jenny -就表示只有2人。

输入样例:

1
2
3
4
5
6
5
bob 11 101 102 103 104 105 106 107 108 108 107 107
peter 8 1 2 3 4 3 2 5 1
chris 12 1 2 3 4 5 6 7 8 9 1 2 3
john 10 8 7 6 5 4 3 2 1 7 5
jack 9 6 7 8 9 10 11 12 13 14

输出样例:

1
jack chris john

思路:

1
简单的排序

C++代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
#include <map>
#include <set>
#include <regex>
#include <stack>
#include <queue>
#include <math.h>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <iomanip>
#include <iostream>
#include <algorithm>
#include <unordered_map>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int dir[4][2] = { {1,0} ,{-1,0},{0,1},{0,-1} };
struct node {
string name;
int cnt;
set<int> s;
bool operator < (const node& a) const {
if (s.size() != a.s.size()) {
return s.size() > a.s.size();
}
else {
return cnt < a.cnt;
}
}
};
int main()
{
int N;
cin >> N;

vector<node> person;
for (int i = 0; i < N; i++) {
node t;
cin >> t.name >> t.cnt;

for (int j = 0; j < t.cnt; j++) {
int tag;
cin >> tag;
t.s.insert(tag);
}
person.push_back(t);
}

sort(person.begin(), person.end());

for (int i = 0; i < 3; i++) {
if (i >= N) {
cout << " -";
}
else {
if (i != 0) {
cout << " ";
}
cout << person[i].name;
}
}

return 0;
}
/*

*/
CATALOG
  1. 1. L2-021 点赞狂魔 (25 分)
    1. 1.0.1. 输入格式:
    2. 1.0.2. 输出格式:
    3. 1.0.3. 输入样例:
    4. 1.0.4. 输出样例:
    5. 1.0.5. 思路:
    6. 1.0.6. C++代码: