F_JustWei's Studio.

L2-019 悄悄关注

字数统计: 707阅读时长: 3 min
2021/04/22 Share

L2-019 悄悄关注

新浪微博上有个“悄悄关注”,一个用户悄悄关注的人,不出现在这个用户的关注列表上,但系统会推送其悄悄关注的人发表的微博给该用户。现在我们来做一回网络侦探,根据某人的关注列表和其对其他用户的点赞情况,扒出有可能被其悄悄关注的人。

输入格式:

输入首先在第一行给出某用户的关注列表,格式如下:

1
人数N 用户1 用户2 …… 用户N

其中N是不超过5000的正整数,每个用户ii=1, …, N)是被其关注的用户的ID,是长度为4位的由数字和英文字母组成的字符串,各项间以空格分隔。

之后给出该用户点赞的信息:首先给出一个不超过10000的正整数M,随后M行,每行给出一个被其点赞的用户ID和对该用户的点赞次数(不超过1000),以空格分隔。注意:用户ID是一个用户的唯一身份标识。题目保证在关注列表中没有重复用户,在点赞信息中也没有重复用户。

输出格式:

我们认为被该用户点赞次数大于其点赞平均数、且不在其关注列表上的人,很可能是其悄悄关注的人。根据这个假设,请你按用户ID字母序的升序输出可能是其悄悄关注的人,每行1个ID。如果其实并没有这样的人,则输出“Bing Mei You”。

输入样例1:

1
2
3
4
5
6
7
8
9
10
10 GAO3 Magi Zha1 Sen1 Quan FaMK LSum Eins FatM LLao
8
Magi 50
Pota 30
LLao 3
Ammy 48
Dave 15
GAO3 31
Zoro 1
Cath 60

输出样例1:

1
2
3
Ammy
Cath
Pota

输入样例2:

1
2
3
4
5
6
7
8
9
11 GAO3 Magi Zha1 Sen1 Quan FaMK LSum Eins FatM LLao Pota
7
Magi 50
Pota 30
LLao 48
Ammy 3
Dave 15
GAO3 31
Zoro 29

输出样例2:

1
Bing Mei You

C++程序:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
#include <map>
#include <set>
#include <regex>
#include <stack>
#include <queue>
#include <math.h>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <iomanip>
#include <iostream>
#include <algorithm>
#include <unordered_map>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int dir[4][2] = { {1,0} ,{-1,0},{0,1},{0,-1} };
int main()
{
int n;
cin >> n;

unordered_map<string, bool> names;
for (int i = 0; i < n; i++) {
string name;
cin >> name;
names[name] = true;
}

int m;
cin >> m;

int sumCnt = 0;
map<string, int> nodes;
for (int i = 0; i < m; i++) {
string name;
int cnt;
cin >> name >> cnt;
sumCnt += cnt;
nodes[name] = cnt;
}

bool flag = true;
double ave = sumCnt * 1.0 / m;
for (auto it = nodes.begin(); it != nodes.end(); it++) {
if (!names[it->first] && ave < it->second) {
flag = false;
cout << it->first << endl;
}
}

if (flag) {
cout << "Bing Mei You";
}

return 0;
}
/*

*/
CATALOG
  1. 1. L2-019 悄悄关注
    1. 1.0.1. 输入格式:
    2. 1.0.2. 输出格式:
    3. 1.0.3. 输入样例1:
    4. 1.0.4. 输出样例1:
    5. 1.0.5. 输入样例2:
    6. 1.0.6. 输出样例2:
    7. 1.0.7. C++程序: