F_JustWei's Studio.

L1-077 大笨钟的心情

字数统计: 477阅读时长: 2 min
2021/04/28 Share

L1-077 大笨钟的心情

有网友问:未来还会有更多大笨钟题吗?笨钟回复说:看心情……

本题就请你替大笨钟写一个程序,根据心情自动输出回答。

输入格式:

输入在一行中给出 24 个 [0, 100] 区间内的整数,依次代表大笨钟在一天 24 小时中,每个小时的心情指数。

随后若干行,每行给出一个 [0, 23] 之间的整数,代表网友询问笨钟这个问题的时间点。当出现非法的时间点时,表示输入结束,这个非法输入不要处理。题目保证至少有 1 次询问。

输出格式:

对每一次提问,如果当时笨钟的心情指数大于 50,就在一行中输出 心情指数 Yes,否则输出 心情指数 No

输入样例:

1
2
3
4
5
6
80 75 60 50 20 20 20 20 55 62 66 51 42 33 47 58 67 52 41 20 35 49 50 63
17
7
3
15
-1

输出样例:

1
2
3
4
52 Yes
20 No
50 No
58 Yes

坑点:

当出现非法的时间点时,表示输入结束,这个非法输入不要处理。(合法时间段是[0,23])。

C++程序:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <map>
#include <set>
#include <regex>
#include <stack>
#include <queue>
#include <math.h>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <iostream>
#include <algorithm>
#include <unordered_map>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int dir[4][2] = { {1,0} ,{-1,0},{0,1},{0,-1} };
int main(){
vector<int> moods(24);

for (int i = 0; i < 24; i++) {
cin >> moods[i];
}

int t;
while (cin >> t && t <= 23 && t >= 0) {
cout << moods[t] << " ";
if (moods[t] > 50) {
cout << "Yes" << endl;
}
else {
cout << "No" << endl;
}
}

return 0;
}
/*

*/
CATALOG
  1. 1. L1-077 大笨钟的心情
    1. 1.0.1. 输入格式:
    2. 1.0.2. 输出格式:
    3. 1.0.3. 输入样例:
    4. 1.0.4. 输出样例:
    5. 1.0.5. 坑点:
    6. 1.0.6. C++程序: