L2-036 网红点打卡攻略
一个旅游景点,如果被带火了的话,就被称为“网红点”。大家来网红点游玩,俗称“打卡”。在各个网红点打卡的快(省)乐(钱)方法称为“攻略”。你的任务就是从一大堆攻略中,找出那个能在每个网红点打卡仅一次、并且路上花费最少的攻略。
输入格式:
首先第一行给出两个正整数:网红点的个数 N(1<N≤200)和网红点之间通路的条数 M。随后 M 行,每行给出有通路的两个网红点、以及这条路上的旅行花费(为正整数),格式为“网红点1 网红点2 费用”,其中网红点从 1 到 N 编号;同时也给出你家到某些网红点的花费,格式相同,其中你家的编号固定为 0
。
再下一行给出一个正整数 K,是待检验的攻略的数量。随后 K 行,每行给出一条待检攻略,格式为:
n V1 V2 ⋯ V**n
其中 n(≤200) 是攻略中的网红点数,V**i 是路径上的网红点编号。这里假设你从家里出发,从 V1 开始打卡,最后从 V**n 回家。
输出格式:
在第一行输出满足要求的攻略的个数。
在第二行中,首先输出那个能在每个网红点打卡仅一次、并且路上花费最少的攻略的序号(从 1 开始),然后输出这个攻略的总路费,其间以一个空格分隔。如果这样的攻略不唯一,则输出序号最小的那个。
题目保证至少存在一个有效攻略,并且总路费不超过 109。
输入样例:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
| 6 13 0 5 2 6 2 2 6 0 1 3 4 2 1 5 2 2 5 1 3 1 1 4 1 2 1 6 1 6 3 2 1 2 1 4 5 3 2 0 2 7 6 5 1 4 3 6 2 6 5 2 1 6 3 4 8 6 2 1 6 3 4 5 2 3 2 1 5 6 6 1 3 4 5 2 7 6 2 1 3 4 5 2 6 5 2 1 4 3 6
|
输出样例:
样例说明:
第 2、3、4、6 条都不满足攻略的基本要求,即不能做到从家里出发,在每个网红点打卡仅一次,且能回到家里。所以满足条件的攻略有 3 条。
第 1 条攻略的总路费是:(0->5) 2 + (5->1) 2 + (1->4) 2 + (4->3) 2 + (3->6) 2 + (6->2) 2 + (2->0) 2 = 14;
第 5 条攻略的总路费同理可算得:1 + 1 + 1 + 2 + 3 + 1 + 2 = 11,是一条更省钱的攻略;
第 7 条攻略的总路费同理可算得:2 + 1 + 1 + 2 + 2 + 2 + 1 = 11,与第 5 条花费相同,但序号较大,所以不输出。
思路:
模拟
c++代码:
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92
| #include <map> #include <set> #include <stack> #include <queue> #include <math.h> #include <vector> #include <cstdio> #include <string> #include <cstring> #include <sstream> #include <iomanip> #include <iostream> #include <algorithm> #include <unordered_map> using namespace std; typedef long long ll; const int INF = 0x3f3f3f3f; const int dir[4][2] = { {1,0} ,{-1,0},{0,1},{0,-1} }; int _map[205][205]; int N, M; set<int> s; vector<int> path;
int checkCost(vector<int> path) { if (path.size() - 2 != N || s.size() != N) { return -1; }
int cost = 0;
for (int i = 1; i < path.size(); i++) { int t = _map[path[i - 1]][path[i]]; if (t == 0) { return -1; } cost += t; }
return cost; } int main() { cin >> N >> M;
while (M--) { int x, y, cost;
cin >> x >> y >> cost; _map[x][y] = _map[y][x] = cost; }
int K; int cnt = 0; int minCost = INF; int minPos = 0; cin >> K;
for (int i = 1; i <= K; i++) { int n; path.clear(); s.clear();
cin >> n; path.push_back(0); for (int j = 0; j < n; j++) { int t;
cin >> t; s.insert(t); path.push_back(t); } path.push_back(0);
int cost = checkCost(path);
if (cost != -1) { cnt++; if (cost < minCost) { minCost = cost; minPos = i; } } }
cout << cnt << endl; cout << minPos << ' ' << minCost;
return 0; }
|